Maintenance History Errors

Incident Report for Auto Integrate

Resolved

This incident has been resolved.
Posted Mar 20, 2025 - 07:19 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 20, 2025 - 07:00 CDT

Identified

We are aware of an issue displaying maintenance history in some scenarios, we have identified the source of the issue and will roll out a fix as soon as possible.
Posted Mar 20, 2025 - 06:22 CDT
This incident affected: Web App.